Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-10-2000, 08:45 AM
Posts: n/a
1990 300E, 129k mi, 17" AMG monoblock II and 215/45/17 Dunlop SP Sport 8000's....

Nothing in the suspension has ever been replaced in this car and I'm not having any problems at all with it, but I was wondering it there is anything that I should be looking for with this mileage? One tech told me that since the rear shocks seemed to have dirt sticking to them as if they were wet, it's likely that they need replacing. If that's the case I'm thinking I'll just put bilsteins all around and some Eibach springs, or the sportline kit. But if it's not an issue, then I can hold off for a bit. Any advice? Thanks...

Chris Singh
1983 300D 200k+ (stopped odometer)
1990 300E 123k
1999 E430 12k
Reply With Quote
Old 02-10-2000, 10:44 AM
Registered User
Join Date: Nov 1999
Location: Lynnwood, WA, USA
Posts: 178
If you experience increased impact hardness or a hard ride then it is time to replace the shocks. Shocks typically last about 60K miles before losing their effectiveness. A couple of percentage lost in damping makes a big diffenence in feel.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
1993 300E 3.2 For sale: Needs Tranny Work otherwise VG condition. onrails Mercedes Cars For Sale 1 07-19-2004 10:05 AM
Will a 16v potentiometer work on 300E? WANT '71 280SEL Tech Help 1 07-16-2003 06:22 PM
Will mercedes startac work in a 1992 300E? Badinfo Tech Help 1 03-08-2003 12:36 PM
300E 5speed Front Suspension Shaun McCarren Tech Help 1 07-19-2001 09:51 PM
92 300E 2.6 headlights dont work... BmwTek Tech Help 1 05-23-2001 08:31 PM

All times are GMT -4. The time now is 08:30 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page