Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-19-2003, 11:25 PM
Registered User
Join Date: Jul 2003
Posts: 60
Angry Windshield Fluid not Spraying


Thanks again for your help in the past.

I got a minor problem, I was hoping if anyone had any suggestions.

Here is the problem.

I used my windshield fluid few days ago to clean the window. I didnt experience any problems.

Today, I tried to use the washer and the wiper worked fine but no fluid coming out.

Opened the hood and saw the Windshield fluid 1/2 full, I had someone push the windshield washer handle in to activate the fluid motor, I heard no sound from the bottom of the resarvoir tank. I dont know if it is supposed to be very quite.

I opened the fuse box, checked 3 fuses in the engine bay, and 2 fuses under the seat. They all look good.

I dont know if this had anything to do with the problem few days ago, I was looking at the Climate control numbers by pressing REST button for 15 seconds to read various setting such as engine temp and other data it provides, did this do anything, I dont think so, but wanted to mention this.

Thanks in advance for your advise and input.

1998 E 320
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:11 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page