Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-01-2003, 03:06 PM
Registered User
 
Join Date: Jan 2002
Location: Colorado Springs, CO
Posts: 1,006
Question A/C clutch failure

Hi all,

My '87 300D A/C clutch has failed. The rubber in the clutch is visibly shredded as seen from looking down from the top of the engine bay. The compressor can be turned by hand.

This is the 3rd time its happened on this car/compressor. The first time, last year one week before I went on vacation. It was "fixed" under warranty at the shop that did the first work (compressor/clutch dates to 2/02). Then it failed again about 200 miles from home (on a 6400 mile RT roadtrip). Both times, a short, 1 sec or so, high pitched noise was heard. That second time, a more experienced mechanic at the shop repaired it and they said the first time the gap was wrong. This last time, I did not hear the high pitched noise. But in all cases the rubber was destroyed. The car was hit on the passenger side in 2/03 & the fan belt was a bit shredded. The drivers side had no damage. Not sure if that is related in this case.

Any ideas on why this is a repeat problem?

I have searched the archives for information about replacing this clutch and think I can handle that.

Thanks,
__________________
Brian Toscano
Reply With Quote
  #2  
Old 09-01-2003, 04:50 PM
Registered User
 
Join Date: Sep 2002
Posts: 134
Hi,
Do you have the klima working on your car, it should disconnect the clutch if it starts to lock before any damage...did the belt survived this failure (clutch locking)? some suggested bypassing the klima, is this the worst consequences, I mean damaging the clutch but not cutting the belt...
regarding changing the clutch, first you need specific tools for that, may be loaned from Autozone or so..Second, I THINK you need to take off the radiator to get more space..
thanks
kamal
Reply With Quote
  #3  
Old 09-03-2003, 07:51 AM
Registered User
 
Join Date: Jan 2002
Location: Colorado Springs, CO
Posts: 1,006
Electronics shut things down before other things happen. The belt is fine. The spring plate is now in two pieces, the rubber ring no longer connects the two parts.

Thanks,
__________________
Brian Toscano
Reply With Quote
  #4  
Old 09-04-2003, 01:06 PM
Registered User
 
Join Date: Sep 2002
Posts: 134
Hi,
if the klima is working, it should prevent damaging the clutch....that is what i understand..there is test in the maintenance CD for the klima...they say: spray a jet of water at the belt at the Ac compressor, while the AC is on...the klima should detect such little slipping and cut the compressor...if not, replace klima (after doing other tests)...
SO, I am not sure if the failure you have is due to not working klima or this is something could happen with the klima working!!??
Somebody might clearify this,
thanks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 01:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page