Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 03-28-2000, 10:16 AM
fz500sel's Avatar
Happy now in paradise!
Join Date: Nov 1999
Location: Venice, FL - "sharktooth capital of the world"
Posts: 712
Thanks for the post. I took the power coming into the front console switch straight over to the connector for the motor power and when I touched briefly to the termninals, I could hear the motor start to crank, so I'm sure the motor is fine (at least on this door.I haven't tried the other door yet). From the Haynes manual I have, it looks as though if either switch (front console or door) is crapped out the system won't work. The manual shows that the output from the center console switch is used as the input to the door switch (as thought they are in series rather than parallel).

84 500SEL EURO 87K
85 300DT 267K (not my miles tho)
Reply With Quote
Old 05-06-2000, 07:29 AM
Posts: n/a
I recently purchased an '88 300e with what appears to be same same rear window problem
that you had with your 300D.
Did you ever find the source of the problem?
I'm just beginning to look into this on my


Reply With Quote
Old 05-10-2000, 01:17 AM
fz500sel's Avatar
Happy now in paradise!
Join Date: Nov 1999
Location: Venice, FL - "sharktooth capital of the world"
Posts: 712

The drivers side rear window wiring harness to the motor had shorted to the door frame. When I went to follow the harness I found the four wires melted together and just laying in there. I opened up the b pillar and found that the wiring harness had been cut and taped off. The previous owner stated that he had no knowledge of this and that he never used the rear window so he wasn't aware it wasn't working. I doubt that anyone would not have knowledge that the harness was cut and taped off.

As for the passenger window, I haven't fixed it yet but I feel strongly that it may be a shorted harness as well, seeing that I have the infamous rear passenger footwell water puddle whenever it rains heavily.

I guess Steve B was right when he said I definitely have 2 different problems.

Email me if you have any further questions (

Good luck,

84 500SEL EURO 87K
85 300D 267K (and still goin' strong)
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
W123 Rear hatch door trim 300D vs. 300TD LaughingGravy Diesel Discussion 8 08-05-2004 01:12 PM
tinted windows and a new rear window seal cooty Diesel Discussion 4 07-01-2004 02:41 AM
300D elect windows quit? Fredmburgess Diesel Discussion 5 11-02-2003 11:12 PM
1983 240D Rear Windows don't work... Carrameow Tech Help 4 04-14-2003 06:37 PM
Rusty rear floorpans, 123 300D turbodiesel Diesel Discussion 4 09-14-2001 07:19 PM

All times are GMT -4. The time now is 08:06 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page