Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-22-2000, 10:03 PM
bobs320
Guest
 
Posts: n/a
About Three days ago my '96 S320 started turning off the radio when the wipers were turned on, then today the windows stopped moving when all this is going on it runs fine but the SRS light is on. Local dealers are saying about 2 weeks before they can look at it, Any Ideas ????
Reply With Quote
  #2  
Old 06-22-2000, 10:19 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
It sounds as if you have a connection problem somewhere. You could have a fuse that is just partially connecting, causing a power drain somewhere else. Or you could have some wires touching somewhere.

------------------
Benzmac:
Donnie Drummonds
1992 500E (very soon I hope
1981 280GE SWB
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM
Reply With Quote
  #3  
Old 06-23-2000, 08:51 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Failure of electrical section of ignition switch is common on this model. Sounds like this might be your problem as well. Not for a inexperciened technician.

------------------
MERCEDES BENZ MASTER GUILD TECHNICIAN
ASE MASTER TECHNICIAN
27 YEARS DEALER M.B. Shopforeman
190E 2.3 ITS RACECAR
1986 190E 16V
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical problems or gremlins whunter Diesel Discussion 9 09-08-2012 07:17 PM
Electrical problems djjeant Tech Help 1 08-16-2003 09:46 PM
1993 300te 4matic electrical problems rbwein Tech Help 3 02-11-2003 08:50 PM
1999 E300D Electrical Problems searaypaul Diesel Discussion 11 05-10-2002 06:52 PM
Electrical problems with 96 E320 ss109 Tech Help 1 08-14-2000 03:01 PM



All times are GMT -4. The time now is 07:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page