Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-14-2000, 09:51 AM
Registered User
Join Date: Feb 2000
Location: Springfield, MO
Posts: 270
The other night I was driving to the gas station and filled her up. When I came back out, the battery was so dead it wouldn't even begin to turn over. So, I recieved a jump. When I was driving around town, and had to stop at a trafficlight for like mroe than 10-15 seconds, a message in the message center came up that said "Traction Control Error" and the ASR, SRS, and ABS lights came on. The car had minimal acceleration, but after 20 yards or so, the message went off, and the car acted normal. After about an hour of driving and when I was going back home, I had to stop at a traffic light for an extended period of time. Not only did the beforemention happened, but all of the electrical systems shut down to the point where I didn't have enough juice to roll the windows down! I put it in neutral, and reved the engine to about 2k RPMs, and the car came back around. I took the car into my MB dealer Friday, and the computer did not throw any alarms and everything checked out. I thought (and so did he at first) that the alternator was bad, but it checked out fine. Now, he is going to run some more extensive tests ttoday, but do any of you guys know what could be the problem? Cheers!

[This message has been edited by ss109 (edited 08-14-2000).]
Reply With Quote
Old 08-14-2000, 02:01 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
As all computers are voltage sensitive, I'll bet that the charging system is at fault. Over charging has been a problem as well as undercharging. Also have seen many W210 cars w/loose battery cables. Remember that battery isn't maint free, needs water!
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
E320 Electrical Problems? guyever Tech Help 4 04-14-2004 04:45 AM
New member--2000 E320 fuel problems Mr986 Tech Help 2 03-16-2004 06:00 PM
97 E 420 Electrical Problems mmmshop Tech Help 1 07-02-2002 02:56 PM
Stalling Problems with 94 E320 B. Nixon Tech Help 2 06-05-2002 08:19 PM
'96 E320 electrical glitch jdoyle Tech Help 1 12-24-2001 09:27 PM

All times are GMT -4. The time now is 02:45 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page