Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-10-2000, 06:54 PM
Registered User
Join Date: Aug 1999
Location: ajax, ontario, canada
Posts: 773
when i press the airconditioner or dehumidifier buttons of my 190e2.6, with the fan turned on, the airconditioner compressor does not engage (the vented air remains warm and there is no additional load on the engine, as seen from the vacuum gage while at idle).

i've checked the fuses and everything seems to be fine.

i understand that there is a thermostat in the evaporator that is also in the compressor electrical loop. How do i check this, or is it best done by a mechanic?

are there other things that i should check, before i bring the car in?

Reply With Quote
Old 07-10-2000, 10:21 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
I would bet that you are out of refrigerant or your belt is slipping. You will have to take this repair to a tech if you don't have the diagnostic equipment.

Donnie Drummonds
1991 GMC Syclone
Reply With Quote
Old 07-10-2000, 11:50 PM
Registered User
Join Date: Aug 1999
Location: ajax, ontario, canada
Posts: 773

if i am out of refrigerant, will i have ruined my compressor, as i have been testing it for a while? The refrigerant is mixed with lubricating oil, right? When i turn it on, i do not hear any additional noise from the engine bay, listening closely.

anyway, i will take it up with the service advisor when i turn in my car for its scheduled service in 2weeks.

Reply With Quote
Old 07-11-2000, 01:00 AM
Larry Delor's Avatar
What, Me Worry?
Join Date: Jun 1999
Location: Sarasota, Fl.
Posts: 3,028
There is a nifty little switch that prevents the compressor from engaging if you are low on freon...thereby saving you from ruining it. (nifty little idea)

03/83 300D 184k
07/73 280 160k
-88 other 153k

[This message has been edited by Larry Delor (edited 07-11-2000).]
Reply With Quote
Old 07-13-2000, 12:18 AM
Super Moderator
Join Date: Apr 2000
Location: Falls Church, VA
Posts: 5,315
You may wish to arrange for a line of credit before you take the car in to have the AC worked on - see my post "Cold AC but No Money"

Good luck.

Reply With Quote
Old 07-13-2000, 01:28 AM
Registered User
Join Date: Aug 1999
Location: ajax, ontario, canada
Posts: 773
i hope the prognosis is not that bad, but if it is, then i will just tough it out with the few months of summer here in canada. The only problem will be to demist the windshield when it rains, but maybe the heater can do the job ...

i would then use the money for 400e brakes and/or a SportLine suspension, which will then be easier to justify to myself ...
Reply With Quote
Old 07-26-2000, 10:43 PM
Registered User
Join Date: Aug 1999
Location: ajax, ontario, canada
Posts: 773
The prognosis came in today. The service rep recommended replacement of the compressor. As expected, the price is in the "GET OUTTA HERE!" category. "... For a while there, that sounded like TWO-THOUSAND-TWO-HUNDRED-DOLLARS ... "

in short, i decided to not have it replaced, as we only have 3months of warm weather here in canada. It's just that i do most of my long-distance driving in the summer ...

i would rather spend the money to improve the handling and braking ...
Reply With Quote
Old 07-26-2000, 11:52 PM
Registered User
Join Date: Jun 1999
Location: Los Angeles, Calif, USA
Posts: 521
It is just a recommemdation as you said. It is nice to have verything new. But is it necessary? What is actually wrong with the system? Is the compressor leaking or making unusual noise? Don't give up until you know what is going on. It may be just a sample fix as Donnie stated.


[This message has been edited by be459 (edited 07-27-2000).]
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
W123 Turn Signal stopped working dave1shere Diesel Discussion 12 07-30-2013 08:42 PM
560sl odometer and speedometer not working robaincltnc Tech Help 6 04-18-2008 08:47 AM
72 220D Odometer not working Mario Slipac Diesel Discussion 7 08-15-2002 09:21 PM
Blower Not Working Don Hicks Tech Help 3 08-14-2002 12:48 PM
Rear defroster not working larrysiny Tech Help 0 11-16-2001 08:21 AM

All times are GMT -4. The time now is 04:27 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page