Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-13-2000, 04:38 PM
Posts: n/a
Hi all,

I took my 500E for the 105K mile service, and asked them to flush radiator as well. They also replaced the thermostat stating that diagnostic revealed it did not open all the way.

Now it runs really hot in slow traffic or spirited driving reaching 115 or higher when it used to run about 90 to 100 degrees. I was pissed and took it back to the dealer with a big what's up with this temp? This time they decided to exchange the thermoclutch on the engine fan and checked the new thermostat and told me it was fixed (wrong!).

It still runs hotter than it ever did. I put in some water wetter but it did not help much. My question is what the hell could they have done to my car in the 105k service that would have messed up the cooling? They certainly can't seem to figure it out and I hate the idea of them just replacing parts until they stumble onto something.

Thanks in advance for all suggestions,

[This message has been edited by EricH (edited 08-13-2000).]
Reply With Quote
Old 08-13-2000, 10:14 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
These v-8's are difficult to purge correctly. Have them replace the thermostat again, just to be sure they have a good part in the car. Now there is a tool called an Airlift. This thing will vacuum all of the air out; then suck coolant into the void. This will get all of the air out of the engine.

Be sure the auxillary fans are working.

Donnie Drummonds
1991 GMC Syclone
Reply With Quote
Old 08-13-2000, 11:04 PM
Posts: n/a
Hi Benzmac,

Thanks for your reply. The aux. fans do come on when the a/c is selected, but I haven't seen them come on with the a/c turned off, even though the dealer said they tested these. Should they come on when the a/c is not on and if so what temp?

Reply With Quote
Old 08-14-2000, 12:14 PM
Registered User
Join Date: May 1999
Location: Berkeley, CA
Posts: 199
Hey Eric:

Who did the service work? I would like to avoid using such dunderheads.

Reply With Quote
Old 08-14-2000, 09:37 PM
Posts: n/a
Hi Revbond,

The shop in question is the dealer on Broadway and 29th in Oakland. Its the closest to me, and up until this incident they have given me friendly and good service. I like the service advisor, Oscar, and overall they have been fair. I'm going to give them another chance to fix this before making a decission about them. Let's hope its as easy as getting the air purged out of the system.

Reply With Quote
Old 08-17-2000, 04:15 PM
Posts: n/a
make sure the stat is the right way round, if it is in backwards she will run hot.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
500E Euro Headlight Question 300EVIL Tech Help 4 09-21-2004 11:28 PM
Any 500E owners in RHD countries? Greg in Oz Performance Paddock 8 09-21-2004 09:25 PM
78 300D cooling and tranny question muybweno Diesel Discussion 1 05-20-2002 01:19 AM
500E cooling experiments EricH Performance Paddock 18 08-30-2000 12:34 AM
500E 16" Tire Question DSinger Wheels & Tires 5 06-19-2000 11:35 PM

All times are GMT -4. The time now is 09:10 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page