Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-02-2000, 12:21 PM
KWB
Guest
 
Posts: n/a
Having problems with 1991 350SDL battery going dead if the car is not started weekly.
Having this problem with a new fully charged battery and the old (good?) battery. All cables appear to be clean and tight. The current drain with everything off is 15ma but it jumps to approx. 28 ma. every 1 to 2 sec and back to 15ma. What is normal current drain? Checking with digital meter so I might not be seeing everything. Also had the seatbelt connected light stay on during a trip with belts fastened but it appears ok now.
Reply With Quote
  #2  
Old 09-02-2000, 05:08 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
I don't think I would worry about 28ma. Draws caused by trunk bulbs etc. usually range around 200ma. I would guess that the spec for that car would be 25-50ma.

With a diesel I would try and monitor the glow system. If the system comes on or stays on intermittantly it will keep the battery week. Often a hard onee to catch.

------------------
Steve Brotherton
Owner 24 bay BSC
Bosch Master, ASE master L1
26 years MB technician
Reply With Quote
  #3  
Old 09-05-2000, 11:47 AM
Registered User
 
Join Date: Apr 1999
Location: Apex, NC USA
Posts: 176
Try disconnecting things such as the glow plug relay. Mine did the same and it turned out to be the power antenna that kept running after turning off the ignition.

------------------
1991 350 SDL
125,000 miles
Reply With Quote
  #4  
Old 09-05-2000, 06:54 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Most of the 1991 cars have a 2-piece radio, with the tuner in the trunk. The tuner can stay on & draw power. When you disconnect battery to install a-meter the radio will quit drawing it's 400ma. Try hooking up meter w/out losing this info. Or turn radio on w/meter already on(USE 10A scale!!).
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
[HELP - ELECTRICAL] tracing battery drain / ammeter usage ard Tech Help 24 01-09-2007 11:16 PM
intermitent dead battery ("+*#!) MarkM Diesel Discussion 7 12-17-2004 09:11 AM
Battery drain when parked DarylM Tech Help 7 07-21-2004 04:01 PM
500E Battery Drain Problem Persisting charnett Performance Paddock 6 01-15-2004 03:08 PM
Battery Drain RUH52 Tech Help 3 05-01-2001 12:37 AM



All times are GMT -4. The time now is 01:14 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page