Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-15-2000, 11:54 PM
Benzman500
Guest
 
Posts: n/a
my speedo on my 85 500sel euro is right at anything under 35 or 40. After that espically on the interstate it will say i am doing 80 and have got clocked at 90. what could cause this a bad cluster or something like that.
thanks

------------------
Dan Younes
---------------
1985 euro 500sel 223k
1986 420sel 86k soon 2 be
1981 300sd 285k sold
1979 240d 298k sold
1983 300sd 272k sold
1989 chrysler 2.2l Turbo
Leabaron 140k
1989 Dodge Carvan Se 295k
1994 S500
(hopefully someday)
Reply With Quote
  #2  
Old 09-16-2000, 12:24 AM
SW SW is offline
Registered User
 
Join Date: Aug 2000
Location: Houston, TX. USA
Posts: 590
I had the same problem with my old '89 190e euro. The speedo cable was not connected to the back of the speedo properly. It was not threaded onto the speedo enough, there was about two more turns to go before it was properly tightened. Try disconnecting the cable and redonnecting it. Good luck.

------------------
'82 300D Turbo 218k miles
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
300e instability on crosswinds and high speeds radunegru Tech Help 5 08-20-2004 12:52 PM
Can I move hardtop back and forth while crusin at low speeds on SLK230? Black98SLK230 Tech Help 3 11-14-2003 04:50 PM
Feeler: LTB: C43 high miles, 210 E55 motor w/ low miles omegabenz Mercedes Cars For Sale 4 07-14-2003 11:44 PM
84 SD low mileage, high $$$ Gregg B Diesel Discussion 2 04-07-2002 10:47 PM
Speedo jumps at low speeds L Rowe Tech Help 3 03-30-2001 12:17 PM



All times are GMT -4. The time now is 02:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page