Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-25-2000, 08:59 AM
Posts: n/a
'87 260E (175k). Electrical gremlins sprouting--a couple of nights ago started car--outside temp gauge did not work. Having read about problems in this forum, I thought oh well something else not to work but after restart it worked fine. Second problem, yesterday I started car and fan control did not work on any setting. I shut car down and restarted, still no go--after I put it in gear it sounded as though starter briefly engaged with a loud screeching noise but happened only once. After getting home and putting car in park it happened again and I shut the car off and looked for a blown fuse to get the fan working again. After searching all fuses, I restarted car and fan worked fine and so far after 4 starts and driving about 25 miles, the screeching noise did not return. Does anybody have any idea what's going on--otherwise car runs fine and all electrical seems to work ok for time being.

Jerry O
1987 260E 175k miles
Reply With Quote
Old 09-25-2000, 09:43 AM
Join Date: Sep 2000
Location: Sugarland, TX
Posts: 285
Check the fuse for the blower, it is located in its own little housing mounted near the fuse box, a black plastic box about 2" long by 1" wide with a cap that unsnaps. Open the box and I'll bet you'll find the fuse (a flat metal link) has broken from STRESS, replace it with a 30 amp fuse.

Reply With Quote
Old 09-25-2000, 07:46 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
In the fuse box, you will see many fuses. At times, I have seen them crack with a hairline crack. You will have to move them around to find this.

Donnie Drummonds
Reply With Quote
Old 09-26-2000, 11:02 PM
Registered User
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
Another thought, the blower rotor is stalling (screeching sound). it may intermittently seize up. The fact that you state the fan is now working OK to me eliminates the fuse. The screeching noise sounds like a dry bushing in the motor. Or you may have some foreign object in the blower case that gets into the fan rotors and the falls out. I had this on my 87 BMW. The squirrel cage just disintegrated. What a racket.. Check it out. If it does seize up, you will burn out the motor if the fuse doesn't fry first..

Jeff Lawrence
1989 300e
2000 Dodge Grand Caravan SE
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical problems or gremlins whunter Diesel Discussion 9 09-08-2012 06:17 PM
W124 Electrical Gremlins CSX293 Diesel Discussion 1 10-15-2004 08:08 PM
300sdl electrical gremlins? daverdla Tech Help 1 03-27-2004 11:22 AM
E 320 Cabriolet Electrical Gremlins timroperco Tech Help 2 05-11-2003 06:10 PM
Help the Electrical Gremlins are Attacking! Steve A Diesel Discussion 1 11-29-2001 07:40 PM

All times are GMT -4. The time now is 02:47 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page