Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-06-2001, 09:36 AM
wjm's Avatar
wjm wjm is offline
Join Date: Dec 2000
Location: Suburban Detroit, MI
Posts: 692
I have a copy of the Service Bulletin that I received from Steve some time ago. Post your fax # and I can send it to you.

As closure to this particular issue. It turns out the the difference between the computer Mercedes recommends upgrading to and the original is the software on the chip... and at that only 18 bytes of it.

I've run into a few additional people who have had this problem. We went ahead and simply replaced the chip with the newer version (got a copy from someone who had the new computer) and it has so far solved the issue and eliminated the check engine light #19 code.

Reply With Quote
Old 08-06-2001, 12:52 PM
JimF's Avatar
'94 S500: only 793 sold!
Join Date: Mar 2001
Location: San Diego, CA
Posts: 1,924
Thumbs up . . yes, it works!

To add a bit to Willy's post, it does work.

Tested it on my friend's '94 S420 with the same DTC 19 code and the CE light has not come on. Been over three weeks now.

Yes, it's about 18 bytes that does the trick, so Benzmac, it's now a reality, not fantasy. Good for us!!!
Regards . . . . JimF
'94 S500 Cpe

Visit my Mercedes Web Page
Reply With Quote
Old 08-06-2001, 12:57 PM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Can you burn me a couple??
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
Old 08-06-2001, 01:03 PM
wjm's Avatar
wjm wjm is offline
Join Date: Dec 2000
Location: Suburban Detroit, MI
Posts: 692
Sure. Send me your address

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light - O2 vs Coolant temp JMyers ML, GL, G-Wagen, R-Class, Unimog, Sprinter 2 11-23-2004 08:37 AM
ML430 check engine light? mmaeser ML, GL, G-Wagen, R-Class, Unimog, Sprinter 0 08-30-2004 07:54 PM
Does Check Engine Light Reset Itself? screedchan Tech Help 7 09-27-2002 11:17 AM
Check engine Light! Bad idle! moomoomeow Tech Help 2 04-25-2002 08:02 AM
check engine light came on after extremely rough idling! apprentice Tech Help 8 07-09-2001 08:02 PM

All times are GMT -4. The time now is 05:39 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page