Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-09-2001, 03:04 PM
Posts: n/a
My wife and I love our 1986 420 SEL, but the A/C won't cool it. I have been going crazy trying to make my center vents work with my mechanic for two weeks. Back to the dealer twice for parts, one switchover unit and the second trip for heater elements. Now we've got complete vacuum but still the center vents won't open up. My mechanic now tells me I need a new pushbutton climate control unit. Problem is I just purchased and put in a rebuilt pushbutton climate control unit from "Adsitco" a month ago.

Is there a definite way to find out if the pushbutton unit is the culprit?

Your advice will be much appreciated.

Chasing My Tail,
Reply With Quote
Old 07-09-2001, 04:42 PM
longston's Avatar
Another View. . .
Join Date: Dec 2000
Location: Mark West, CA
Posts: 787
W-126, Right?

I assume that the system is fully charged and the compressor is coming on?

Have you checked the vacuum pot on the driver's side of the transmission hump inside the car? That's what opens the center vents. Also have you tested the pressure switch on top of the dryer/accumulator? If you bypass that switch and your vents open, it's defective.

The only other thing I can think of is the mechanical actuator in the dash.
"We drive into the future using only our rearview mirror."
- Marshall McLuhan -

Scott Longston
Northern California Wine Country...
"Turbos whistle, grapes wine..."
Reply With Quote
Old 07-09-2001, 05:25 PM
Posts: n/a
"vacuum pot"

Scott, your giving me hope! What function does the vacuum pot serve? like a reservoir? Is it just under the drivers side transmission cover mat?

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
I got A/C Finally! How come heat isn't coming out of central vents? s500 Tech Help 8 09-13-2003 12:52 PM
126 Windshield Vents Getting A/C Vice Ambient in "split" position stephenson Tech Help 0 08-11-2003 03:35 PM
Burn smell from a/c vents E320 94, help! acha3 Tech Help 7 07-23-2003 10:34 PM
A/C Side Vents - '92 300E git0 Tech Help 3 06-14-2003 08:49 PM
Removing A/C vents in 300E pezzy Tech Help 2 01-11-2001 08:12 AM

All times are GMT -4. The time now is 11:47 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page