Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-25-2001, 03:47 AM
DWag2
Guest
 
Posts: n/a
420SEL A/C problems

I have had a number of problems with the A/C control on my 1988 420 SEL. If I have the heater giving warm air and then select a cooler temp, I can't get the heater to go back to warm without an ignition cycle. I also have a problem keeping the fan running in auto or low. Auto works ok when min temp is selected. The fan usually won't turn on initially in any selection, although if I move the ignition key slightly while tapping the brake it will come on. The A/C compressor will only work about half of the time, but when it does it cools just fine and usually keeps working. I replaced the push button control unit, but still have the problems. Any help would be greatly appreciated.
Reply With Quote
  #2  
Old 10-31-2001, 02:39 PM
Registered User
 
Join Date: Nov 1999
Location: Germany
Posts: 63
Had similar problems with 87 420SEL; replaced bits and pieces with no luck - and then took it to good MB mech, who replaced pushbutton unit, aux water pump and other items. Bottom line: W126 a/c problems are beyond capability of most home mechanics; having the right diagnostic tools is a must. Bite the bullet and take it to an expert.

Joe B.
Reply With Quote
  #3  
Old 10-31-2001, 03:04 PM
MIKE FREEMAN
Guest
 
Posts: n/a
REPLACE YOUR IGNITION SWITCH. IT IS DEFINATLY BAD!
AFTERWARDS IF ANY OTHER PROBLEMS OCCURE ,THE CAR IS EQUIPPED WITH ONBOARD SELF DIAGNOSTICS.
IT'S A SIMPLE MATTER TO TEST AT X11/4 BUT REMEMBER IT LOOSES MEMORY EVERY TIME THE KEY IS TURNED OFF.
MF
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Two Problems: A/C & Oil Light Tump Tech Help 6 06-18-2002 05:57 PM
A/C - Auxillary fan problems Thomas Zellers Tech Help 2 08-29-2001 08:19 AM
SL560 Fan & A/C problems Thomas Zellers SL Forum 1 08-24-2001 06:40 PM
420 SEL a/c and gauge problems constellation95 Tech Help 3 05-15-2001 07:34 AM
A/C Problems LEE190E Tech Help 1 06-24-2000 03:36 AM



All times are GMT -4. The time now is 06:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page