Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 11-18-2001, 07:44 PM
Joseph Bauers
Posts: n/a
123 windshield wiper problem

In my 1979 300TD wagon, I have just experienced a most perplexing problem. I turned on the wipers today in a brief rain, and they worked fine. When I went to turn them off, they would NOT turn off. The switch on the turn signal stalk works in the fast position and the normal position, but it won't work in the delayed wiper posion and it won't turn them off. I had to pull the fuse to avoid driving with wipers moving on my dry windshield.

I assumed the probem was most likely the switch, so I took a unit I had taken off a parts car and connected the big plug from it in place of the big plug from the one still on the car--but the results were the same.

I suppose there could be two bad switches, but I wonder if a bad relay could cause this problem. Anyone with any knowledge of this strange phenomenon would be most appreciated.
Reply With Quote
Old 11-19-2001, 09:08 AM
Dirty Ern
Posts: n/a
I don't have any experiance with MB wipers but an old Chevy truck I had had a switch in the wiper motor that turned it off.

You break the circuit at the wiper control and when the arms get to the park position, the switch in the motor shuts it off. May be out in left field here, but its worth a thought.

Reply With Quote
Old 11-19-2001, 10:04 PM
Joseph Bauers
Posts: n/a
Problem solved! It WAS the relay. For those of you interested, should you experience the same symptoms I did, the relay is located on the firewall behind and slightly to the left of the instrument cluster. It is easiest to remove it by taking the instrument cluster out. In my case, I solved the problem by tapping the relay on my work bench a few times, and the malfunction disappeared.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield wiper quit Norseman Tech Help 1 01-02-2005 08:26 PM
Windshield Wiper Cal Ratcliff Tech Help 3 10-17-2004 12:53 AM
Windshield and wiper issue BauhnBuster Tech Help 10 03-19-2004 04:21 PM
W140 (S500) Windshield wiper system suiteR Tech Help 2 09-24-2003 08:51 PM
Windshield Wiper Problem Blackbenzz Tech Help 2 04-11-2001 09:30 PM

All times are GMT -4. The time now is 06:53 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page