Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-29-2001, 07:27 PM
J.HIDALGO's Avatar
Registered User
 
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
Question Any known problems for the 210?

We know the 124's have "common" problems (depending on the year) with the AC, engine harness, head gasket, front cover seal, radiator neck, etc.
Are there any known problem areas with the 210's? Specifically, from the 98's to the present.
I did a search but, I could not find any specific answers.
__________________
J.H.
'86 300E
Reply With Quote
  #2  
Old 11-29-2001, 08:34 PM
JCE's Avatar
JCE JCE is offline
Down to the Wear Bars
 
Join Date: May 1999
Location: So Kalifornia
Posts: 2,189
J.H.

There is a pretty good overview starting on 96-2000 w210s in the open discussion forum.

http://www.peachparts.com/shopforum/showthread.php?threadid=27236
__________________
John

2003 Firemist Red/grey leather SL 500
2015 Palladium Silver/black mbtex GLK 350
1987 Smoke Silver/burgundy mbtex 300E Sportline (SOLD)

Click to see 87 300E
Reply With Quote
  #3  
Old 11-29-2001, 09:17 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
The 98 320's are seemingly good so far. I have seen a pattern failure of the 97 420's related to transmission failure.

The 96 and 97 320's have the old style engine which was a workhorse, but they were mated to the new tranny. The mate was not a good one and I have seen transmission problems with them as well.

I would stick to the 98 and later 210 unless you go with a 96 E300d. It has the early style tranny.

I will add that we own a 96 E300d and it is a wonderful car. It has over 240k miles! Original engine and tranny. (Never been apart, but I have NEVER missed a service!)
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS

Last edited by Benzmac; 11-29-2001 at 09:55 PM.
Reply With Quote
  #4  
Old 11-29-2001, 09:32 PM
Registered User
 
Join Date: Jan 2000
Posts: 140
I would watch out for the electrial hardware problem for the W210. My driver's side power seat failed twice when I had it in the first month of ownership. The dealer replaced the power seat motor and switch on the door. I don't have any problem since then.

Also, there are MANY complains about the fuel gauge not register at FULL. It does happen on my 99 E430 SOMETIMES. However, if you top the tank off with another 0.25 gallon, you MIGHT BE able to fool the fuel gauge.

Other than those problems, W210 is a very nice car to drive.

Good Luck
Car Nut
99 E430 Sport
Reply With Quote
  #5  
Old 11-29-2001, 10:52 PM
Southern's Avatar
Registered User
 
Join Date: Jan 2000
Location: Carol Stream, Il, USA
Posts: 605
Its strange that you should ask if there are any known problems with the W210.

My battery went dead today on my 98 E320. I believe that the batterys life spent its 9 lives. The car was purchased in Sept. of 1997. Fortunately the battery died in my garage (didn't need a tow).

Other than my sunroof problems and a few burned out light bulbs, this car has been very reliable.

With snow tires on in the Chicago winters, the car handles very well. Without snow tires on in the Chicago winters, the car handles very poorly.

I would recommend synthetic oil and change it more often than the FSS recommends.
__________________
Ray
1998 Mercedes E320, 200K Miles
2001 Acura 3.2TL, 178K Miles
1992 Chevy Astro, 205K Miles
Reply With Quote
  #6  
Old 11-29-2001, 11:27 PM
J.HIDALGO's Avatar
Registered User
 
Join Date: Jul 1999
Location: Jax, FL
Posts: 1,785
Lightbulb Keep it coming...

If you noticed, no particular trends so far. Just individual problems. That is definetely good news.
__________________
J.H.
'86 300E
Reply With Quote
  #7  
Old 11-30-2001, 10:52 AM
Registered User
 
Join Date: Jun 2000
Location: Plano, TX
Posts: 2,503
I've owned a '98 E300 turbodiesel for about 3.5 years nows. Mine seems to be about the most problematic 210 around - which is not to say it's bad.

I've experienced a failure of the transmission electronics; a problem which locks the transmission in limphome mode. The car is not immobilized, but neither is it very useful. I've seen a pattern of this failure in early diesels, but never in gasoline cars.

I've also had several glow plugs fail. Again, this problem is unique to the diesel. I've also seen a pattern of shorter than normal glow plug life in the 606 diesel engine.

What else? The engine mounts have been replaced to cure a vibration/noise problem. The CD changer died.

Other than that, just routine maintenance - A & B services, brake fluid changes, and engine coolant changes. I'm seeing about 25K-30K mile life on the Michelin MXV4 tires, which is a bit short for a modestly performing tire, but no real issues.

Let me finish by saying despite a few niggles here and there it is a truly amazing car. Incredibly smooth & quiet at speed. Beautiful to drive. Great seats. High quality materials. I'd buy another one in a second.
Reply With Quote
  #8  
Old 12-01-2001, 01:06 PM
Southern's Avatar
Registered User
 
Join Date: Jan 2000
Location: Carol Stream, Il, USA
Posts: 605
One more problem that I noticed: the radio reception (AM and FM) fades in and out on at times. I am not sure if this is related to the antenna/antenna cable or the head unit. The antenna is located in the rear window on the 98 models and up. The cd and cassette work fine.

FYI, I replace my battery last night and everything is back to normal. I had the original battery tested and it shorted out under load.
__________________
Ray
1998 Mercedes E320, 200K Miles
2001 Acura 3.2TL, 178K Miles
1992 Chevy Astro, 205K Miles
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
A Class problems, problems, problems. Eddie Gilmartin Featured Cars 5 07-21-2005 07:37 PM
Questions about C220 problems j0e Tech Help 2 06-28-2003 02:55 AM
Return of idle problems - '91 190E 2.3 sbourg Tech Help 11 05-19-2003 11:25 AM
95s 320 problems are they common?AC/LOCKING system/head gasket leaks joe cantalino Tech Help 0 05-14-2003 11:00 PM
Two problems over the weekend Indy300CE Tech Help 3 03-11-2002 06:33 PM



All times are GMT -4. The time now is 05:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page