Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-04-2001, 09:17 PM
Joe Stein
Guest
 
Posts: n/a
Unhappy Ok, what did I break know?

This after noon I decided to change oil and rotate the tires on my 1993 500SEL. Checking everything under the hood, I removed the air cleaners and pulled a spark plug on the passenger bank. Everything looked good and I topped all of the fluids. I filled the oil, installed a new oil filter. When I started the car, the engine wanted to die. I took it for a short ride and the engine has no power. Under light throttle, the speed will gradually increase, but under hard throttle, nothing happens. The transmission shifts strange. When the engine idles the RPM oscillates from under 500 to about a 1,000. My wife could hear the noise from the engine oscillating in the house. What are the two looms of wires for that attach right above the passenger side rear cam cover. It appeared that one of the plugs was coming out and I pushed it back in. Thanks
Reply With Quote
  #2  
Old 12-04-2001, 09:21 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
It sounds like you accidentally knocked loose one of the main vacuum lines. This should not be hard to see with the air cleaner off.
__________________
Benzmac:
Donnie Drummonds
ASE CERTIFIED MASTER AUTO TECHNICIAN
MERCEDES SPECIALIST 11 YRS
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
W140 break light part number h_shek Tech Help 9 10-26-2004 08:22 AM
Parking break adjustment affect hyd. breaks? patagrande Diesel Discussion 2 06-06-2004 02:11 PM
Is there really such a thing as Break in Oil ? sdanville Tech Help 12 01-26-2004 09:08 PM
Break Squeal edhayes Tech Help 5 06-14-2001 12:52 AM
Break Squeal edhayes SL Forum 1 06-12-2001 11:56 AM



All times are GMT -4. The time now is 07:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page