Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-28-2002, 10:18 AM
Registered User
 
Join Date: Feb 2002
Location: Philippines
Posts: 111
Outside Temp intermittent display

Guys,

The outside temp display in the instrument cluster of my 1995 C36 does not come on when I turn the engine on. It remains blank for a couple of minutes after starting then comes on by itself, with the correct temperature reading. If I shut the engine off, the cycle begins again.

Perhaps some fellow members here have experienced such a malady and can help me fix it?

Many Thanks

Bong
Reply With Quote
  #2  
Old 03-28-2002, 09:54 PM
Banned
 
Join Date: Nov 2001
Location: Cape Cod Massachusetts
Posts: 1,427
??????

Does this model have a low engine speed cut out to avoid false readings at idle or stops? Someone on another post reported the replacement he got from the MB dealer had 5 vs. 4 pins with the fifth pin used for this newer model feature.
Reply With Quote
  #3  
Old 09-01-2002, 05:10 AM
benzine
Guest
 
Posts: n/a
I had exactly same problem. Had the MB dealer have a look but it gave up again a few weeks later. Found a highly technical solution of my own. Smack the top of the dashboard cluster with your hand a few times ..... it works just dandy - just like all good old fashioned tube radios. Mine has worked for a year since with no problems.
regards
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
outside temp on dash display 300 sdl stangsteve Diesel Discussion 4 11-24-2003 09:48 AM
Outside temp display problem on E500 TomE500 Tech Help 18 06-17-2003 03:59 PM
newbie and outside temp display mbdad Tech Help 8 11-02-2002 03:42 PM
outside temp display gone bad again arif Tech Help 2 08-31-2002 04:44 PM
Funky outside temp display problem solved. blackmercedes Tech Help 2 05-30-2002 05:09 PM



All times are GMT -4. The time now is 01:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page