Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-04-1999, 10:01 PM
gpstein
Guest
 
Posts: n/a
this has shown up over the last couple days and seems to be getting worse
the car is a 79 280ce m110 engine
always strong, great runner, i have always kept it well tuned,ie, good cap,
rotor,wires plugs, filters,etc. new fuel pump and injectors 2 years ago, new filter 1 mo ago.well heres whats happening . car is cold from overnight. start the car
fires up right away starts a higher rich idle like its warming up then
starts to slow down like its going to die, then speed up and slow down,
does this maybe 6-8 times before leveling to a steady idle
then as we start to drive off as i give it gas it cuts off fast and starts chugging
the more gas the less anything happens then it dies .it will restart but i
have to put the pedal to the floor and keep the gas on and the engine speed
up to keep from chugging. here is a clue maybe. all this happened just
a while ago, we had to drive 120 miles to get home. well up to speed on the
highway all the power was there no problem when i stepped on it going 80 it
flew up to 100 in a hurry just like always.
drove home great until we got it back down to street speed then i couldnt
step on it without missing and chugging again. im thinking distributor? .any ideas would be really appreciated.let me know what other kind of things you might need to know
thanks
greg
  #2  
Old 04-05-1999, 12:08 AM
Benzmac
Guest
 
Posts: n/a
It sounds like it is running lean. For wat reason? I don't know.

------------------
Benzmac:
ASE CERTIFIED MASTER AUTO TECHNICIAN
LEAD TECHNICIAN FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


  #3  
Old 04-06-1999, 08:41 PM
M.B.DOC
Guest
 
Posts: n/a
The fuel mixture sounds like it is too lean, you also should check the compression as these engines can jump timing on the intake camshaft. Remove the valve cover & inspect the cam timing. Look around the engine ares for loose vacuum lines that could lean out the fuel mixture.
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange charging/electrical problem GregS Diesel Discussion 16 10-20-2004 07:57 PM
Acceleration problem Golden Luck Tech Help 0 02-19-2004 09:25 PM
Running Problem bcm494 Tech Help 2 02-09-2001 09:34 PM
running problem 560 sel Doug AZ Tech Help 7 08-28-2000 05:07 PM
300D electrical problem? horn wont blow when a/c is running straighteight Tech Help 2 05-09-2000 07:37 AM



All times are GMT -4. The time now is 01:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page