Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #16  
Old 07-13-2002, 04:32 PM
quist100
Guest
 
Posts: n/a
S-500 Window Problems

I have tried the cal. proceedure that Gillybenztech has suggested.
It does not work and I really don't want to remove the battery and risk not being able to reset any of the windows, so I guess I am back to doing what Stevebfl has suggested. Have the shop take the motor out and give it a couple of turns and then try again.

I will inform all on results,

Thanks,
Mark
Reply With Quote
  #17  
Old 07-13-2002, 05:51 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
I didn't say that. I said that the car doesn't have hall sensors and rotating the motors won't do anything on any of the systems.

The later system can get its counting screwed. I will give an example to explain as I don't actually understand it completely.
I am making this up as far as the numbers. The window takes 150 pulses to go from top to bottom. The accepted numbers assigned to the top position of the window are what are set. After a number of resets it is possible to get out of range. The computer will accept as position numbers 1 through 1000. If you tell it that 350 is at the top then it subtracts 150 to get the bottom. If through resetting the number for the top gets interpreted as 100 then there is not enough numbers to go down. You then restart the point by disconnecting the battery or controller which sets you back to 1000. Again the numbers and the example are given to aproximate the concept.

I would suspect that you might have a bad switch, remeber that there is a separate switch position for the express function. Just because the window goes up doesn't mean the express position of the switch is working.

I was told that to test the express position one could hold the button down (both in the up position and the down position) for ten seconds after the window stopped. This will accomplish the initialization but will also pop the circuit breaker in the motor which can be heard. The point being that if one heard the pop then one knew the express function of the switch was working. I have tryed this an never could hear it. But I have always done it in a noisy shop. If it works let me know, try it on a window that works first. If it smokes the car don't tell me (bg).
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #18  
Old 07-13-2002, 07:00 PM
quist100
Guest
 
Posts: n/a
S-500 window Problems

OK,
I am trying to understand what is going on. M.B.Doc (Moderator) says the system in my 1994 S 500 has Hall Effect Sensors and that is why I need to remove the motor and spin it. (Sorry Stevebfl) But Steve says it does not.

If I try the 10 second breaker pop, does it reset itself? Or will I have other problems trying this. The window will auto down fine and it will auto up all the way and then reverse around 2 inches EVERY time. Does this not mean that the auto up part of the switch works OK??? Keep in mind the regulator is new and the motor is new.

Thanks,
Mark
Reply With Quote
  #19  
Old 07-13-2002, 07:29 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Won't be the first time I have been wrong.

I am sure there are two systems and I think the new system is after at least 96 maybe 98. Maybe we will need someone to look it up. If it makes it till Monday I'll do so.

I stand by the concept I explained in the case of hall effect systems and numbers. I suppose one could rotate the thing backwards with the motor separated from the gear mechnism to run the numbers back up, but it is easier to disconnect the battery or reset with a scanner.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #20  
Old 07-13-2002, 07:39 PM
quist100
Guest
 
Posts: n/a
Windows cont.

I guess I will wait till someone can confirm the system I have. Can Steve or anyone answer the second part of my last reply? Should I do the 10 sec. breaker pop or the batt. disconnect or just wait for further responses??

This is a minor problem which is chewing up a lot of everybodies time. I really appreciate all the help. Thankfully it is a rear window and is seldom opened.

Thanks Again,
Mark
Reply With Quote
  #21  
Old 07-13-2002, 08:12 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
According to the advise I got in the training seminar I refer, the idea of the ten second check when initializing the windows was to accomplish two things at once. Normally the check of the switch wasn't necessary. If it triggers the thermal breaker it will reset quickly. That info was part of the same advice. I have tried it and nothing went wrong I just couldn't hear the breaker or it didn't break but nothing went wrong. I tried it on a car I was initializing. Everything initialized but I just couldn't hear and it wasn't that big of a deal. I'll try it agian I'm sure.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #22  
Old 07-13-2002, 09:41 PM
JimF's Avatar
'94 S500: only 793 sold!
 
Join Date: Mar 2001
Location: San Diego, CA
Posts: 1,925
It's happend to me

on my '94 S500 twice in three years. Both times at very unexpected times. Nothing was replaced, battery was not removed, etc..

Both times it was fixed by following the 'sketchy' procedure given in your Owners Manual on page 68.

It states:
If the door windows cannot be fully opened or closed automatically by pressing the button past the point of resistance (e.g. after the vehicle battery change), press the UP SIDE of the power window switch until the window is completely closed and hold for additional 2 seconds. Repeat the procedure for each window

The automatic full opening and closing procedure of the door windows should now be restored.


As I remember, I also moved the windows down to the bottom also holding the switch for a few seconds after the window bottomed. Then repeated this at the top doing this LAST!

Also found that the Mercedes "2 seconds" can be more like "5" or "6". But this procedure (as modified) worked like a charm!
__________________
Regards . . . . JimF
-------------------
'94 S500 Cpe

Visit my Mercedes Web Page

Last edited by JimF; 07-13-2002 at 10:04 PM.
Reply With Quote
  #23  
Old 07-14-2002, 02:04 PM
quist100
Guest
 
Posts: n/a
Window Problem

I have again tried the factory way explained in the owners manual. It does not work. No matter what I do, the window in auto up mode goes all the way up and then back down about 2 " I have tried the first detent and the second auto up detent in my attemps. My Pass. front window now appears to be doing similar things like my Pass. rear window. This one won't reset either.

Now a new problem has appeared. The Pass. front door pulls in when closed but pops back slightly as if it has closed too far. Any idea's.

Thanks,
Mark
Reply With Quote
  #24  
Old 07-14-2002, 02:23 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
The door has an adjustment for how far it is pulled in. It obviously has to go past the second latch to be latched by the second latch. After the given time the vacuum is released letting the door back to the latch point. Wouldn't be smart to have the door held closed only by the vacuum linkage. The amount it releases is adjustable. But there always will be a certain amount that the door moves when released.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #25  
Old 07-14-2002, 03:22 PM
quist100
Guest
 
Posts: n/a
S 500 Door

Thanks Steve,

The door never did this before. What kind of adjustment do I make?

Thanks,
Mark
Reply With Quote
  #26  
Old 07-14-2002, 07:05 PM
JimF's Avatar
'94 S500: only 793 sold!
 
Join Date: Mar 2001
Location: San Diego, CA
Posts: 1,925
Sorry that it didn't work!

Have you tried the battery disconnect and then the owners manual procedure? Make sure that you have the radio codes if you do.
__________________
Regards . . . . JimF
-------------------
'94 S500 Cpe

Visit my Mercedes Web Page
Reply With Quote
  #27  
Old 07-15-2002, 01:31 AM
Registered User
 
Join Date: Jan 2002
Location: Virginia
Posts: 193
OK, I think i have what your looking for......

First, let me say....this is definately the most confusing post in the forum!!!!!!!
My 93 300SE has the same problem on the front passenger window. It Goes up, then comes down about an inch or two....ONLY IN AUTO MODE. The problem does not get worse or better with time. A technician at the dealership is a good friend of mines, and he said not to worry about it unless i use the remote express opening and closing consistantly (this is where you can put the windows and sunroof up and down with the remote and key). He also said, it is a problem that is not really worth dissasembling the door for. If you can, just live with it, if not, the door must be dissassembled.

Also, to fix your Pneumatic assist in your door, MAKE SURE KEY IS NOT IN IGNITION!! Go in the trunk and pull fuse #9. Wait ten seconds and replace it. This should fix it!
__________________
"If I teach you half of what I forgot, you'll still have enough to compete with most people"
Reply With Quote
  #28  
Old 07-15-2002, 10:31 AM
quist100
Guest
 
Posts: n/a
S 500 Window and door problems

Thanks Benz_Man,

But the door fix does not work. I pulled the fuse and waited 10-11 seconds. The door does the same thing. It pulls in fine and the a few seconds later pops back out a little. I never noticed this before, maybe it has always done this but I never heard the pop noise before. The drivers door does it too, but you can barely hear it.

As for the window, I guess I will just have to live with it.

Thanks to all for the help,
Mark
Reply With Quote
  #29  
Old 07-15-2002, 01:15 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
It looks like it kepts getting more confused. But, I wasn't confused. All the techniques I described were appropriate.

I gave one technique untried to do a simple test on the switch and nobody has discuused any other diagnostic techniques only initiation techniques.

I'm not even going to get into the current confusion about how the doors work.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #30  
Old 07-16-2002, 07:26 PM
Snowman's Avatar
Registered User
 
Join Date: Feb 2002
Location: Chicago,IL
Posts: 230
Re: I'm not trying to 'pick' on you. .

Quote:
Originally posted by JimF
so please accept my apology if it seemed that way.

But using rules of our language, no one would know that you had a problem other than by quessing. The operative word is my as in " . . express feature doesn't work on all the windows in my W140". Using the word 'the' changes it to fact or comment about W140s!

Hey, don't blame me, it's how we communicate or don't as the case may be!

But the solutions suggested will work.

And what happend to Mark?
Oh no I wasn't offended by your remark, but I hope I didn't come across as demanding when I said if anyone had an answer. The reason I didn't say my W140 is because it's the one that my mom drives. It's legally not mine but I guess for simplicity's sake, I could just say so.
__________________
1985 500SEL 124k miles
2001 Honda Civic EX
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:50 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page