Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-17-2000, 12:01 PM
Posts: n/a
The verdict: the new alt was scrap.

It's being replaced right now. It was producing just enough current to close the warning lights relay, which is activated by the blue wire at the alt plug, which is why the lights were off.

Thanks all for your help.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
82 300D Idle Problems? openback Diesel Discussion 1 01-21-2005 12:48 PM
92 300D front door speakers. Problems with size NickMendoza Car Audio and Multimedia 5 11-11-2004 04:45 PM
Electrical problems in '82 300D Dusty-NZ Diesel Discussion 3 06-14-2003 09:43 PM
1982 300D Transmission Problems cgraves Diesel Discussion 0 05-02-2003 03:46 PM
Cooling system problems: 83 300D car54 Diesel Discussion 10 10-08-2002 04:35 AM

All times are GMT -4. The time now is 09:07 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page