Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-18-2001, 06:54 PM
pmizell's Avatar
Benz Zealot
 
Join Date: Jun 2001
Location: Houston, Texas
Posts: 838
'90 300 E mono wiper update

The wiper blade arm on my 300E (the single blade type) is currently in an extended position, which makes the blade unusable because it hits the windshield molding in that position. It suddenly just threw out the other day.

I took off the blade and ran the wiper and it still wipes back and forth with the bob and weave motion, but it makes some unpleasant noises, like it needs some grease or something.

Did I blow out the wiper transmission? Is this part lubricated and if so where is the resevoir to add fluid to?

If I need to replace the transmission, what's it gonna set me back?

Thanks for any help
Reply With Quote
  #2  
Old 06-19-2001, 03:34 AM
pmizell's Avatar
Benz Zealot
 
Join Date: Jun 2001
Location: Houston, Texas
Posts: 838
Thanks a bunch. Looked through old posts including MBenz's "how-to" and I think it just needs a little lube in there to operate properly.

Gonna pull it out tommorrow and check it out.

Thanks for the help
Reply With Quote
  #3  
Old 06-19-2001, 02:35 PM
Registered User
 
Join Date: Apr 2000
Posts: 530
My tech actually rebuilt mine. Don't ask me how, but I know it can be done.
__________________
1988 Mercedes-Benz 260E
Reply With Quote
  #4  
Old 06-19-2001, 10:15 PM
pmizell's Avatar
Benz Zealot
 
Join Date: Jun 2001
Location: Houston, Texas
Posts: 838
Well, I took out the assembly, cleaned the arm, lubed all the gears (that I could see), put it back in and it still is bobbing and weaving about 2 inches too far out. My '24 inch blade hits the molding still.

The damn thing runs and sounds just fine, but I guess it just blew out a gear or something and extended out.

So my next plan is to try a '22 inch blade, which would work perfectly, if I can find one that fits.

Anyone know if the smaller '90 models (190 etc) use a '24 inch wiper or a '22 and if so, is the blade connection to the wiper arm the same as my 300E?

Arghhh, I guess I can get a used assembly for $65 over the internet but I don't wanna take that damn thing apart again .

Thanks for any help
Reply With Quote
  #5  
Old 06-20-2001, 09:15 AM
avusblue
Guest
 
Posts: n/a
Could anyone point me towards . . . .

MBenz's "How To" that's referred to? Is this a website or done by searching this forum?

Thanks from a new member!

Dave
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
What price to sell my 300 SD for? (blown tranny) PhilK Off-Topic Discussion 4 06-29-2003 02:22 PM
300 Turbo Diesel engine into 240D (manual tranny) IZELJIC Diesel Discussion 5 06-19-2003 01:39 AM
300e wiper blade insert momentum Tech Help 9 12-18-2002 09:20 PM
300 D turbo tranny swap out (easy?) xtant Tech Help 1 03-06-2000 10:13 PM
300 sel wiper blades rosterga Site Feedback 2 02-02-2000 09:49 AM



All times are GMT -4. The time now is 03:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page