Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 01-23-2002, 08:19 AM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
SO Dan (gillybenztech) you are saying the PSE pump is responsible for the problems that JERE is having with his back-up antennas & trunk handle!!! Just as I posted to begin with!!
The mod that had to done on earlier cars was already on this car, ie; S500 means 1994 & later.
ALSO the inside trunk release is done by running the PSE central locking pump, customer says that the trunk opens when putting car in reverse!!
ALL of this leads to problem with PSE(central locking pump) problems.
CLOSING assist ONLY pulls the trunk & doors shut!! Nothing else.
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Old 01-23-2002, 10:31 AM
Registered User
Join Date: Feb 2000
Location: Columbus Ohio
Posts: 709
Old South

According to my tech at the MB dealer there was a modification made in 1995 to the trunk latching your car may be a different animal than the problem vehicle
I myself had problems with the latching mechanism(tongue) a couple of years worked for a while to pull out the fuse9in the trunk) to reset the pump.But finally the closing assist pump was replaced.
The door closing assist always worked well though

1992 300SD(140)
Columbus Ohio
Reply With Quote
Old 01-23-2002, 12:43 PM
oldsouth's Avatar
Registered User
Join Date: Feb 2001
Posts: 610
I have already replaced the closing assist pump in the trunk about a year ago when the doors stopped closing themselves. I hope it is not going out again to cause the trunk problem. I don't think it is the pump because I can mess with the latch when the problem surfaces and that usually solves it for a while.
1995 S-350
370K + SOLD
1952 220B Cabriolet
39K kilometers + SOLD
1998 E300D
285K +
2006 E320CDI
130K +
Reply With Quote
Old 01-23-2002, 11:54 PM
Gilly's Avatar
Registered User
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
Either Dan or Gilly is fine.
I left out one important note 2 posts ago where I was quoting stuff:
In Body and Accesories Chapter 6.1, which is the Closing Assist chapter, they have a test for the trunk pull-down also, it's test step 15, on page 33/9. This indicated that the early cars did use CA for trunk pull-down. They also have that same note about the "starting with 118121" it's pulled down by the PSE in parallel with the RTG.
I'm not trying to be confrontational about this. Yes, I do believe the problem is the PSE for several reasons. #1, if it were old enough to be the CA pulling down the trunk latch tongue (pre-118121), it makes no sense why it would do it in reverse, since the PSE is in charge of the reverse rods. Also "Jere" hasn't replied to posts here for awhile, but since he stated the car is an S500, it probably is a newer car, as cars this old (pre-118121) would probably be badged a 500SEL yet.
On Warrens car, I believe that a replacement of the PSE would have repaired a problem with the trunk pull-down, as we have been discussing. Maybe someone referred to it as the closing assist pump, but i think they meant PSE pump, may have used a term more understandable than "PSE". The PSE pump is more understandable if described as the "central locking" pump. As it is, I think PSE can be loosely translated as "Pneumatically Slaved Equipment".
On Old South's car, the more I think about it, the more I think it has to be the latch itself. Possibly the microswitch, but since you observed the cam not properly contacting the switch, make more sense it is a latch problem. You should be able to monitor this just by closing the latch with your finger or a screwdriver.
If it happens quite often, it would be easy to diagnose by simply monitoring the "actual value" screen on an MB tester (HHT or SDS) in the PSE control module.
Reply With Quote
Old 01-24-2002, 10:08 AM
Registered User
Join Date: Feb 2000
Location: Columbus Ohio
Posts: 709
so you think a replacement of the PSE would have repaired my car? this any less expensive to replace than the closing assist pump?

curiously after the replacement of the closing assist pump I have had no other problems...well with that issue anyway!!!

a friend in town who has a 1992 400SE had the same problem except his doors would also fail intermittently.....same fix...they replaced his closing assit pump also

except for my engine problem he and I are running neck and neck on repairs...both of us have had almost identical work done with the exception of power steering pump and rear end problems that I have not had.....but he has not needed an evap core replacement either
Reply With Quote
Old 01-24-2002, 10:27 AM
Gilly's Avatar
Registered User
Join Date: Mar 2001
Location: Evansville WI
Posts: 9,616
No, what I am suggesting is that the replacement of the PSE DID repair your car since the PSE on a 95 controls the action of the striker tongue. Please reread my previous post. The CA pump only controlled the striker tongue up until VIN 118121. Your friends 92 is probably pre-118121 and may very well have needed a CA pump to repair his car.
I am unaware of the cost difference between the CA and the PSE.
Yes there is a modified striker tongue for the post-118121 cars, it is the only one available for these cars. It is faster acting, they had complaints I guess on how slowly the lid closed.
Reply With Quote
Old 01-24-2002, 10:55 AM
Registered User
Join Date: Feb 2000
Location: Columbus Ohio
Posts: 709
the cost of the replacement of the closing assist pump on my car was about $800.00 parts and labor at the MB dealer.The cost was covered by warranty....curiously I was also having occassional problems with my reversing rods not retracting...but all the tech did was to clean the switches that activate them and that seemed to clean up the problem ... that was two years ago and I have not had any more issues with the reversing rods

he did however tell me at the time that I could have the updated latch(that was less probelmatic) from the 1995+ cars installed...however if I chose that I would have to pay $300.00 from my own pocket..I declined
The new pump seems to be faster acting than the old one...also seems to be stronger as I accidently closed the driver's door on a half inch piece of plastic the other day and door closing device snapped the pice in two.....made me wonder what would happen if a child got his hand closed in the door accidently...there is definitely enough force they to break a finger

1992 300SD
Columbus Ohio
Reply With Quote
Old 02-05-2002, 12:24 PM
Registered User
Join Date: Apr 1999
Location: Cincinnati, OH, USA
Posts: 59
Bosch recall

Donnie, didn't you mention that Bosch had a recall on the close assist pumps? What ever became of that and how can I tell if I am purchasing a good one? On my 92 500 SEL I have to slam the drivers' door and trunk shut. The trunk stopped pulling down the lid and the chrome handle does not come out any more either. The drivers door is the only one that will not close automatically. The trunk may be a combination of the other pump you mentioned that is located under the rear seat. I say this because I have had the lights in the trunk to go out again after replacing the fuse in the rear trunk conpartment. This would lead me to believe that the pump under the seat may have problems. I am going to disconnect it and replace the fuse as mentioned before to see if the pump is drawing too much.

Thank You

Fred Berry
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trunk opening? SLeeper SL Forum 7 03-22-2004 03:28 PM
W140 - Problem opening trunk. sab Tech Help 17 01-04-2004 06:44 PM
1992 - 1999 W140 change list.... I need your helps..... akry Open Discussion 5 06-13-2003 02:34 AM
W140 Dash Button for Trunk release not working ckroeger Tech Help 5 12-01-2002 12:01 PM
How to remove/refit horns from 1994 S500 ( W140 series chasis )? Jere Tech Help 3 02-03-2002 01:50 PM

All times are GMT -4. The time now is 08:09 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page