Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-29-2003, 10:56 PM
Registered User
 
Join Date: Jul 2003
Posts: 20
Angry so sad engine lite

MY wife is mad now. I have left town and her 96 c220 is stalling at every stop and the engine lite is on. A code per odb2 was p0101 for air sensor. I disconnected the hot film mass air sensor 2 days ago for a brief moment and the car worked great . I ordered an air mass sensor from this thread despite not really knowing if this was the right thing to do. I would really appreciate any advice on this matter, sooner than later. Thanks in advance. More desperate than ever and at risk per mad wife.
Reply With Quote
  #2  
Old 07-30-2003, 10:49 PM
Registered User
 
Join Date: Jul 2003
Posts: 20
Getting desperate here. What is not interesting about this post? This car stalls when my wife drives it but not when my 15 year old practices his driving in the hood. I have mentioned that it runs best with the mass air sensor disconnected. What gives here? the EC lite is still on. What are the risk on the drivetrain? the Mb mechanics won't see it for another 2 weeks.
Reply With Quote
  #3  
Old 07-31-2003, 06:22 AM
Registered User
 
Join Date: Jan 2003
Location: USA
Posts: 699
Dear tryfunke:

If you only have the ODB2 code "p0101" for a bad MAS sensor, then there's nothing to worry about your drivetrain. Replace the bad MAS sensor and try to clear the EC light code by either disconnecting the battery cables or follow some instruction in your car manual.

I have owned a "recent" (1994) MB gas car and gotten frustrated of all of its miscellaneous and major problems. I have promised to myself that I will never buy another MB gas car. I will only buy old (prior to 1988) MB diesel cars which are much cheaper, much easier to fix and very spacious (e.g. 300SD). I love big cars so that my passengers (and myself) always feel comfortable on long trips. They also drive like a robust tank.

Women only love reliable cars (not like men who like to have a car problem from time to time :-). Get her a Honda Civic/Toyota Corolla or even better Honda Accord/Toyota Camry. She'll never get mad at you again.

Replace MAS and also the air filter.

Best regards,

Eric
Reply With Quote
  #4  
Old 07-31-2003, 03:39 PM
Registered User
 
Join Date: Jul 2003
Posts: 20
Thank you so much for your reply. You are right about woman and their perspective on car problems. I knew I had to deal with this. I am frustrated with the local MB dealers in Toledo and Tiffin. They won't schedule diagnostic test for 2 weeks with a EC lite on. I am told they have a specific tester for this car. the generic code taker put out a p0101 code. What happened next might take you by surprise because it knocked my block off. I replaced the air sensor and reconnected the battery since I was forced to do something or else. I don't believe it made any difference. The car still stumbles in drive at rest and in reverse sometimes. It also does not assume a idle instantly when started but instead it wanders up and down (from 1500 to 500rpm times 2) THe EC lite has not turner on over the last 35 miles. the air cleaner was replaced 6000 miles ago. I sure do appreciate your help. Maybe I need to clear the retained code with a code meter? I still would value any kind of insight in this area. Best wishes
Reply With Quote
  #5  
Old 07-31-2003, 03:59 PM
Registered User
 
Join Date: Jun 2003
Location: Los Angeles
Posts: 40
Vacuum leak??

Have you looked at ALL your vacuum hoses? There are other possibilities, but start with vacuum hoses. Sometimes they are covered under various plastic covers, so take the time to remove such items.
Also, spend a couple hours searching this forum, sometimes the answer is in a post you least expect to find it in

Stevo
__________________
1990 300E 187k Running like a bull on Viagra
Nov2005 UPDATE: 205k RUNNING BULL on vacation...
Reply With Quote
  #6  
Old 07-31-2003, 04:10 PM
LarryBible
Guest
 
Posts: n/a
ericnguyen,

Don't be so sure about not having problems with a Honda Civic. My daughter just bought a brand new one two months ago and it went belly up two days ago. The check engine light came on, a/c quit, radio quit, CD player makes noise and it went into limp home mode.

We are 70 miles from the dealer and my only option is to drive it the 70 miles with it going no faster than 50 miles per hour. They will not send a wrecker or do much to help without limping it in. If this had happened to my new MB they would have sent a rollback to get it or whatever it took to get me taken care of.

NO CAR BRAND EVER MADE IS WITHOUT THEIR PROBLEMS.

Have a great day,
Reply With Quote
  #7  
Old 07-31-2003, 06:24 PM
Registered User
 
Join Date: Jul 2003
Posts: 20
Thank you gentlemen, I certainly feel very greatful for the advice you two have shared. I am made to feel like a bum getting any immediate help for my wife's car at a dealership. This has been a great lession for me. I really cannot advocate having an older merc (96) when you're expected to have a new mercedes (a around here) or stand in this long line and wait since We have an older (dumper) mercedes. That is how I feel. I must say the best experience to date is having a thread like this with people that want to help for just the satisfaction of helping others. BRAVO!
It is really great.
I have traced vacuum lines that I can see and I will try this again. I have not looked under the car for these lines. Are there any known trouble areas to look at? I have spent about 5 hours looking at past post if there are any that appear to be especially forthcoming.
Reply With Quote
  #8  
Old 07-31-2003, 07:36 PM
Registered User
 
Join Date: Jan 2003
Location: USA
Posts: 699
Dear Mr. LarryBible,

Maybe your daughter was unlucky enough to get a bad Honda Civic (probably a potential lemon). I fully agree that every car brand has its own problems. However, considering the fact that the Japanese car makers possibly sell 5-10 times more cars per year in the US than DCAG and they have still been able to maintain a much lower percentage of troublesome new cars, it's pretty safe to say that taking as a whole, Japanese cars (well most of them are made in the US) are way more reliable than those of DCAG. If DCAG were able to sell that many cars in the US, their myriad of troublesome (new) gas cars would possibly bury it in debt due to class-action lawsuits.

Also, a cheapest MB car is about 2.5-3 times more expensive than a basic Honda Civic, it would be no surprise that DCAG must be able to provide better customer service.

Best regards,

Eric
Reply With Quote
  #9  
Old 07-31-2003, 08:27 PM
LarryBible
Guest
 
Posts: n/a
I don't care if a car, TV, refrigerator or anything else costs $150 or $150,000 when a customer has problems with it, the selling company should STAND BEHIND IT.

I BUST MY %&%$# ON A DAILY BASIS FOR MY CUSTOMERS!!!!!! I don't expect anyone that I buy merchandise from to bust theirs for me, but I do expect them to be REASONABLE.

If you want to believe that the only cars that give trouble are MB's then you have the right to do so. Honda's are crap. The only reason my daughter has one is that my Dad has been buying and selling them since he retired in 1983 and has brain washed her.

Honda's are difficult to work on, they have the stupid timing belts that have to be changed every time you turn around, they are always busting the stupid CV joint boots that are a pain in the (*&^*() to replace, the sheet metal is melted down beer cans and will bend at the slightest provocation, the vinyl and plastic in them stink and rots in a short amount of time, It's a royal PITA to change the oil filter, etc., etc., etc.,

These maladies don't stop with the cheap Civics. The Acuras and other high end Jap crap Hondas have the very same weaknesses.

You should call my Dad and praise your great Hondas with him, but it doesn't sell with me.

Have a great day,
Reply With Quote
  #10  
Old 07-31-2003, 09:17 PM
Registered User
 
Join Date: Jul 2003
Posts: 20
let's all play nice in the sand box. I would like to think that my wife's car is in a self healing mode. Could this be possible? Althought it has stalled and runs rough with the new mas sensor periodically,(post 50 miles) it seems to be running better. WIthout being too starry-eyed, the conditions mentioned seem improved presently. The EC lite has not returned. Once more I looked for vac hose problems on the c class and found no loose connections. I notice one vacuum hose goes down below the manifold toward the firewall but lI lose sight of it towards the last spark plug closest to the firewall. It is attached to something I cannot see.
Again, I thank one and all for helping me . I don't know if it is resolved. I will not be able to return to this post after 8-1-03 for a few days so anything or any thought now will really make a difference. thanks
tom o
Reply With Quote
  #11  
Old 07-31-2003, 11:03 PM
Registered User
 
Join Date: Mar 2003
Location: Milwaukee Wisconsin
Posts: 1,149
What's your mileage? Bad gas? Gummed injectors? Spark plugs or plug wires? Dirty air filter? Cat converter? Throttle position sensor? Yes the MAS sensor failed and now the new one has the car running better, but not perfect. Time to step back and review the simpler things.
__________________
Resistance is Futile.
Reply With Quote
  #12  
Old 08-01-2003, 05:49 AM
Registered User
 
Join Date: Jun 2003
Location: Los Angeles
Posts: 40
tryfunke,

I'm with tecqboy. You haven't found any vacuum leaks, its running better than before with new MAS, start listing what you have and haven't done yet.
Starting with inginition system:
ingin. wiring - unplug replug - clean contacts - etc...
spark plugs - cap - rotor -
check all fuses....
check trans fluid and oil......(don't ask)
and so on and so on...........
Add a fuel cleaner to the tank. (do a search on recommended brand)

Also, I agree with Larry about Japanese cars, they are harder to work on than MB's. Big pain, biigg pain Tom son...
AND...... I have heard and read a looot of good comments about MB's C class. Its a keeper. Just has the hicups right now.
Quick story...
Bought a 2001 Toyota Sienna a couple months ago, three days after taking it of the lot the back hatch latch breaks. Got it fixed by dealer, leaving dealer we almost get into an accident.. left break grinds metal to metal when I stomped on the break... last week.. side door handle release button breaks and stays in the door, unable to open and close. I know these things might sound simple, but if you can't open the door to a family van, what the f^^^^ing use of the car..
For the age of the car I really didn't expect to have any problems yet.
If it was a 1996, thats almost 8 years new. There will be a few things that need attention.
ONE more thing. I found a vacuum leak that was hidden under the plastic cover for the distributor cap. I would never have though otherwise. I don't want to sound like a nagging mom but I hope your not just look a the vacuum lines...feel around.. push the connections in just to be safe...

All righty good luck,
Stevo
__________________
1990 300E 187k Running like a bull on Viagra
Nov2005 UPDATE: 205k RUNNING BULL on vacation...
Reply With Quote
  #13  
Old 08-01-2003, 08:48 AM
Registered User
 
Join Date: Jul 2003
Posts: 20
Thanks alot techo and stevo. Well said, "If it aint't broke....YOu haven't fixed it enough. I will be back to give you an update in a week. Duty calls. Thanks for the great advice. I'll check the vacuum,plug ,wires,injectors. If no change, It will go to the hood car spa for some rubbin. check back of the outcome. tomo
Reply With Quote
  #14  
Old 08-01-2003, 10:52 AM
LarryBible
Guest
 
Posts: n/a
tryfunke,

I have been through the emotion you are dealing with many times. After repairing a nagging or elusive problem, you still worry about it. As time goes by, you worry less and less until you just forget that you ever had the problem.

Intermittent problems cause the greatest amount of this emotional feeling.

Have a great day,
Reply With Quote
  #15  
Old 08-01-2003, 11:18 AM
Registered User
 
Join Date: Feb 2003
Location: Durham, NC
Posts: 158
Off Topic Comment

OK, after listening to you all proclaim the negative attributes of owning a Japanese vehicle (which I have heard before), I keep wondering how they keep getting all these wonderful ratings by Consumer Reports, J D Powers and the like. It does not ring consistent with what I know is real world experience. We have all heard the phrase the F-O-R-D stands for Fix-Or-Repair-Daily but I have also heard the phrase T-O-Y-O-T-A stands for Take-Out-Your-Old-Tools-Again!

If any of you subscribe to AutoWeek magazine you will read that during their evaluation of the new Honda Element they have plastic interior pieces falling off.

Something is wrong here with these ratings. My wife recently purchased a new 2003 C230K coupe which has been a perfect car with the exception of a squeak in the panaromic sunroof that Mercedes bent over backwords to get fixed ASAP. After 6 months and 7,000 miles the car has had zero, I repeat zero, problems. Yet the C-Class does not score high on owner satisfaction ratings. I own a 2000 ML320 which, if you read the ratings, is nothing but trouble. My experience, in 4 years of ownership and 38,000 miles I have only replaced two headlamp bulbs and two dash bulbs outside of normal maintainence. I also own a 1995 C280 with 78,000 miles and the only thing that I have replaced that I would consider something that was abnormal was the engine wiring harness (which we all know about). Other than that the car rides and drives like new and is in pristine condition. People who do not know Mercedes or me all think this is still a new car!

I really get sick of hearing from all the these "Ricers" how much better and more reliable their Japanese cars are. As previously stated they are hard to work on (they are designed for ease of assembly instead of repair) and their parts prices are the highest in the industry. I personally find them boring to drive and do not see the attraction.

My bottom line.... If I only had $20,000 to spend on a car, I would rather buy a used Benz than a new something else.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page